Jump to content
  • 0
Sign in to follow this  
wmac

Installation error

Question

I am trying to install Blesta and got the following error and it will not install

 

----------------------------------------
Blesta CLI Installer
----------------------------------------
OK
Checking InnoDB support... OK
Installing database...
96/96 [========================================] 100%
Completed.
Configuring database...
23/23 [========================================] 100%
Completed.
Upgrading database...
4/4 [========================================] 100%
0/0 [========================================] 100%
2/2 [========================================] 100%
0/0 [========================================] 100%
2/2 [========================================] 100%
1/1 [========================================] 100%
1/1 [========================================] 100%
1/1 [========================================] 100%
1/1 [========================================] 100%
1/1 [========================================] 100%
2/2 [========================================] 100%
2/2 [========================================] 100%
15/15 [========================================] 100%
1/1 [========================================] 100%
1/1 [========================================] 100%
5/7 [============================>           ] 71 %<!DOCTYPE html>
<html lang="en">
    <head>
        <meta charset="utf-8">
        <title>Blesta</title>
        <link rel="stylesheet" href="./app/views/errors/css/application.min.css">
        <link rel="stylesheet" href="./app/views/errors/css/font-awesome.min.css">
    </head>
    <body>
        <div class="error-container">
            <div class="program-error">
    <div class="panel panel-default panel-simple">
        <div class="panel-heading">
            <h3><i class="fa fa-exclamation-circle"></i> Something went wrong.</h3>
        </div>
        <div class="panel-body">
            <p>
                Undefined index: total            </p>
        </div>
    </div>
</div>        </div>
    </body>
</html>
 

 

 

Somebody has some workaround for this?

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0
On 6/22/2017 at 5:51 PM, Blesta Addons said:

when you install it from web, you get the same error ?

 

Yes, but I fixed that could finally install Blesta with VestaCP have to make some modification on php.ini and also some on my.cnf

I would like to thank you all we can close this one as solved.

Share this post


Link to post
Share on other sites
  • 0

if you have mysql 5.7 , this can help

MySQL 5.7+

MySQL changed the default behavior in version 5.7.5 to enable "only_full_group_by". If you are using a version newer than that, or if you had changed your MySQL configuration file to enable "only_full_group_by", you will need to remove it. You should update your MySQL configuration file to disable "sql_mode", i.e., don't have it set to "only_full_group_by". You can run the following query to determine what the sql_mode is: SELECT @@GLOBAL.sql_mode, @@SESSION.sql_mode;

https://docs.blesta.com/display/user/Requirements

Share this post


Link to post
Share on other sites
  • 0

The mysql version that I have installed is 5.5.56  and   only_full_group_  is disable, still got the same result on the installation.

 

I am running VestaCP with niginx

Share this post


Link to post
Share on other sites
  • 0

Some update, I could install Blesta and work well on CWP running Apache, reinstall it on VestaCP running only Apache and had the same problem in the installation process, looks like Blesta does not like VestaCP

 

Share this post


Link to post
Share on other sites
  • 0

Update, installed VestaCP on a dedicated Centos 6.9 and got the same issue these are the PHP and mysql info:

PHP 5.6.30 (cli) (built: Jan 20 2017 08:02:17)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v6.1.0 (), Copyright (c) 2002-2017, by ionCube Ltd.
 

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 33
Server version: 5.5.56 MySQL Community Server (GPL) by Remi

Only Apache installed no other proxy.

Share this post


Link to post
Share on other sites
  • 0
On 6/26/2017 at 5:04 PM, wmac said:

Yes, but I fixed that could finally install Blesta with VestaCP have to make some modification on php.ini and also some on my.cnf

I would like to thank you all we can close this one as solved.

can you share your solution, this will help others if they have the same error, and maybe the team can add some tweak in the docs if needed.

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, Blesta Addons said:

can you share your solution, this will help others if they have the same error, and maybe the team can add some tweak in the docs if needed.

Here they are:

 

vi /etc/my.cnf and add the following lines or modify them if they exist in your installation

wait_timeout=2400 
connect_timeout=360


restart mysqld

vi /etc/php.ini and change or add the following lines

memory_limit = 512M 
upload_max_filesize = 512M 
post_max_size = 512M 
max_execution_time = 60


restart apache

as I have the resources I used but I am sure can be less

and that is it could install, configure and migrate without any problems

Share this post


Link to post
Share on other sites
  • 0

memory_limit 128M is fine for blesta

max_execution_time 60 to 90

Default settings in php.ini(cpanel change some of those while you install it) are

memory_limit 128M (for almost all popular script this is fine)

max_execution_time 30 (in 99% cases this is problem,since most apps need more than 30s to finish exec.)

upload_max_filesize 2M (can make you problems if you want to install plugin or theme larger than allowed size for any php app using web interface,if you don't have control of this you can upload files directly with ftp )

post_max_size 8M

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×