Jump to content
  • 0
mukesh

uable to add image in ticket system

Question

12 answers to this question

Recommended Posts

  • 0
17 minutes ago, Paul said:

How are you creating the file? FTP? Sounds like you don't have permissions to it. Try setting it to 777 and try again.

i create folder via ssh

and 755 permission not working

when i changed to 777 than its working

and i attached screenshot in ticket system

Share this post


Link to post
Share on other sites
  • 0

That's not adding but attaching :) can you check that your uploads folder is correct please:

outside Public_html there should be a uploads folder if not it's in your public_html and needs to be moved.

That should be 777 or 700.
inside that you should have a 1 folder this is your company 1.

inside that you should have a support_manager_files folder. Also check the settings: Settings > System > General > Uploads folder

Share this post


Link to post
Share on other sites
  • 0
On 7/15/2017 at 5:31 PM, Licensecart said:

That's not adding but attaching :) can you check that your uploads folder is correct please:

outside Public_html there should be a uploads folder if not it's in your public_html and needs to be moved.

That should be 777 or 700.
inside that you should have a 1 folder this is your company 1.

inside that you should have a support_manager_files folder. Also check the settings: Settings > System > General > Uploads folder

already out side...

unable to attached image.png

Share this post


Link to post
Share on other sites
  • 0

Make sure your uploads directory exists and is defined under Settings > System > General: Uploads Directory.

Some tips:

- The uploads directory should be above your document root or public_html directory so that it's not accessible directly via the web.
- A common path to the uploads directory would be something like: **/home/user/uploads/** 
- Make sure the uploads directory is writable by your web server and cron users. 755 permissions are usually sufficient, but you may need to set it to 777
- Inside the uploads directory, you should have a directory called 1 (for the company ID), and system.
- Plugins typically create their own directories within your company ID directory, but you may need to create them manually.

These are the directories you should have under uploads:

└── uploads
    ├── 1
    │   ├── download_files
    │   ├── invoices
    │   ├── mass_mailer_files
    │   └── support_manager_files
    └── system
 

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, Paul said:

Make sure your uploads directory exists and is defined under Settings > System > General: Uploads Directory.

Some tips:

- The uploads directory should be above your document root or public_html directory so that it's not accessible directly via the web.
- A common path to the uploads directory would be something like: **/home/user/uploads/** 
- Make sure the uploads directory is writable by your web server and cron users. 755 permissions are usually sufficient, but you may need to set it to 777
- Inside the uploads directory, you should have a directory called 1 (for the company ID), and system.
- Plugins typically create their own directories within your company ID directory, but you may need to create them manually.

These are the directories you should have under uploads:

└── uploads
    ├── 1
    │   ├── download_files
    │   ├── invoices
    │   ├── mass_mailer_files
    │   └── support_manager_files
    └── system
 

under 1 download_files and support_manager_files  both are missing

and system also

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, mukesh said:

when i create file under 1 permission denied

How are you creating the file? FTP? Sounds like you don't have permissions to it. Try setting it to 777 and try again.

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, Paul said:

How are you creating the file? FTP? Sounds like you don't have permissions to it. Try setting it to 777 and try again.

cpanel i am trying to change from 755 to 777  [folder 1]  permission also not change

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, mukesh said:

cpanel i am trying to change from 755 to 777  [folder 1]  permission also not change

See if you can in cPanels file manager, maybe the files are owned by a different user?

Share this post


Link to post
Share on other sites
  • 0
Just now, mukesh said:

i create folder via ssh

and 755 permission not working

when i changed to 777 than its working

and i attached screenshot in ticket system

Ok good, so it's working now? I thought it was not allowing you to change the permissions to 777. 777 is probably necessary because your web server runs as a different user than your FTP/cPanel user. Should be fine as long as your uploads directory is above your document root.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×