Jump to content
  • 0
blestatester

That Domain Name is Not Supported (NameSilo + Restricted Packages = not working?)

Question

I am posting this "solution" (bug?) in case anyone else had my issue. 

I realize there are previous threads about this here, here, and here (for example) but I didn't want to further hijack or necro their threads as neither involved NameSilo.

 

  • Issue:  It ALWAYS generates a "That domain name is not supported." and does not show the TLD under "Check Domain Availability"

 

  • Solution:  it was because I (intentionally) set the Package as a "Restricted" package -- it simply does not work with the NameSilo Blesta modules(s).  Once the Package is set to to "Active", it works.
    • I followed Paul's documentation about "Selling Domains" to the letter
      • I did not find documentation or posts stating that Domains couldn't be Restricted Packages.  The documentation simply says "'Active' is the default, 'Inactive', and 'Restricted' are also available."
      • I actually did want to use the module as a Restricted Package to only some existing customers
    • I used "Set Packages" prior to testing the Order so that the appropriate user(s) had access to it
    • I only have a "Domain Package Group" selected and not "Package Group" selected as suggested here.

Hope this helps someone else.

Thanks

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...