Jump to content

Recommended Posts

Chances are pretty good Blesta is unable to connect to your Proxmox server. Make sure TCP port 8006 egress is open on your  Blesta server so it can make an outgoing connection, and that the same port is open ingress on your Proxmox server

Share this post


Link to post
Share on other sites
13 hours ago, Paul said:

Chances are pretty good Blesta is unable to connect to your Proxmox server. Make sure TCP port 8006 egress is open on your  Blesta server so it can make an outgoing connection, and that the same port is open ingress on your Proxmox server

Hi paul, thanks for your response.

I'm sure everything is open since firewall options are all open, and tcp+udp+http+https port 8006 is reachable when i run a test application.

 

I installed a different module now, but it gives me this error:

Internal API When Creating The VM on the node 

 

Also nothing appears in the logs, only that it gets the last used VM id and outputs status ok, but doesn't give api calls back while it can connect since it can find the iso storage and such1

 

Share this post


Link to post
Share on other sites

Has anyone come across a solution for this because I'm having the same issue.  Zero nodes show available in the Package tool for Proxmox.   I have ZERO firewalls between the Blesta server and the Proxmox server so I don't know what else it needs in order to work.

 

Any help would be great.

Share this post


Link to post
Share on other sites

Well... I feel dumb.. 

In case anyone comes across this same exact problem...   you need to do username@pve or username@pam  depending on the user account you used.

Then inside of Proxmox if your not using the root account (highly recommend NOT using root)  then you'll need to create a user (recommend using username@pve) and then assign permissions to the user account.

Then if you have all the information entered into the module then it works just fine.

 

Why do I feel like I'm the one answering my own questions all the time?  🤨

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...