Jump to content
  • 0

Invoice Emailed when that option UNchecked


rebus9
 Share

Question

Some customers on auto-pay do not want invoices emailed, and for them I un-checked the "Invoice Delivery - Email" option when the recurring invoice was created.  (see screenshot)

Problem-- the invoices are still being sent via email overnight.

Any ideas why, and what can be done to fix it?  Disabling the invoice delivery email template is not an option, because some customers DO want invoices via email.

emailedinvoice.jpg

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0
20 hours ago, activa said:

I think it would simple adding a new delivery method called none :)

None is just don't check it. The setting applies only to that specific invoice, not future invoices. The solution here would be an additional option where future invoices created from the recurring invoice would not be set for delivery.

Link to comment
Share on other sites

  • 0
4 minutes ago, Paul said:

None is just don't check it. The setting applies only to that specific invoice, not future invoices. The solution here would be an additional option where future invoices created from the recurring invoice would not be set for delivery.

No, i have hired BA to add this option for us. He qdded q new delivery method called none, this delivery we set it in the setting and all invoices is set to none. So no invoice is send . He told us that he made database changes and some core files i think the delivery class . Maybe he can well explain what he  done for us .

Link to comment
Share on other sites

  • 0
Just now, activa said:

No, i have hired BA to add this option for us. He qdded q new delivery method called none, this delivery we set it in the setting and all invoices is set to none. So no invoice is send . He told us that he made database changes and some core files i think the delivery class . Maybe he can well explain what he  done for us .

Oh ok, that makes sense. To get around that you could go to Settings > Company > Emails and disable both Invoice Delivery (Paid) and Invoice Delivery (Unpaid) email templates. If they are disabled, no invoice emails will go out, and the customer could have email selected as the type. However, I can see how showing "None" may be less confusing to the customer if they login and see Email and wonder why they don't get them.

Link to comment
Share on other sites

  • 0
16 hours ago, activa said:

No, i have hired BA to add this option for us. He qdded q new delivery method called none, this delivery we set it in the setting and all invoices is set to none. So no invoice is send . He told us that he made database changes and some core files i think the delivery class . Maybe he can well explain what he  done for us .

is better to add a new delivery option called None or anything that return true, this way we can mark invoice as sent without sending them, is totally useful for companies that has it own platform and use blesta with API.

Link to comment
Share on other sites

  • 0

This is exactly what I've been waiting for.  To inhibit an emailed invoice, we have to set delivery to Paper (per your instructions in another thread).  But, also per your instructions, that means we have to periodically delete messages in the queue waiting to be printed.  A "none" option would solve all of this.

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...