Jump to content
  • 0
Rokunas

Blesta Installation - Files not writable by Web-Server

Question

Hey everyone, I'm having an issue when setting up my server to meet the requirements for Blesta Installation. 

image.thumb.png.525db8f3fcdf7c6ded6a4e15c751e840.png

I have installed all the required extensions and set up the database, but I can't figure out how to make the files and directories writable by the web server.

I am currently running CentOS 7 with apache installed. 

I have tried using commands like 

chgrp apache /var/www/html/config
chmod g+w /var/www/html/config

and 

chgrp apache /var/www/html/config/blesta-new.php
chmod g+w /var/www/html/config/blesta-new.php

But that didn't help. 

I then tried using FileZilla and giving those folders and files 777 permissions but that was no good either. 

I'm also having the same problem with the recommended requirements tab, I have installed all the extensions but the one which requires files to be accessed by the web server is unsolvable to me. 

image.thumb.png.f6ff69142ff39f6197aba665e0afb9b9.png

I have tried many different methods and tutorials but can't find a solution. 

I hope you guys could help me out ^_^ 

 

Thanks, 

Rokas 

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
3 hours ago, evolvewh said:

You need to rename blesta-new.php to blesta.php and then run the installer. It's named blesta-new.php by default to avoid accidentally overwriting this file if you're upgrading in the future.

I renamed blesta-new.php to blesta.php but it still doesn't work 😕 

Even tried using the ssh installer but that also gives me the same error. 


EDIT :  I've noticed that when I renamed blesta-new.php to blesta.php and tried doing the command

 chgrp apache /var/www/html/config/blesta.php 

it says that the file cannot be found. I have restarted my server few times but the file is still not detectable even though it shows up under LS command. 

Share this post


Link to post
Share on other sites
  • 0
11 minutes ago, Blesta.Store said:

Hi are you still having issues, if so could you please PM me your teamviewer information and I'll try and help you.

Hey, yes. I've sent you a message. 

Thanks

Share this post


Link to post
Share on other sites
  • 0
On 5/22/2018 at 9:00 PM, evolvewh said:

You need to rename blesta-new.php to blesta.php and then run the installer. It's named blesta-new.php by default to avoid accidentally overwriting this file if you're upgrading in the future.

I just have done this, as I want to get rid of one of both (after upgrade, NOT install) ...Result: blesta doesn't work at all,

Share this post


Link to post
Share on other sites
  • 0

If you are upgrading you should NOT delete your blesta.php     You only rename blesta-new.php to blesta.php IF and only if you are doing a new install, if it's an upgrade you can just ignore the blesta-new.php or delete it if you don't like it hanging around.

Also as a suggestion, you should never delete a file if you are not 200% sure of what you are doing, best thing to do would be to rename it to something else so you can move/rename it back if it was not the right thing to do.

If you have your blesta.php from before your upgrade I would suggest restoring it, if not restore your whole account if you have a full backup.

 

Share this post


Link to post
Share on other sites
  • 0
On 5/22/2018 at 8:10 PM, Rokunas said:

Hey everyone, I'm having an issue when setting up my server to meet the requirements for Blesta Installation. 

image.thumb.png.525db8f3fcdf7c6ded6a4e15c751e840.png

I have installed all the required extensions and set up the database, but I can't figure out how to make the files and directories writable by the web server.

I am currently running CentOS 7 with apache installed. 

I have tried using commands like 


chgrp apache /var/www/html/config
chmod g+w /var/www/html/config

and 


chgrp apache /var/www/html/config/blesta-new.php
chmod g+w /var/www/html/config/blesta-new.php

But that didn't help. 

I then tried using FileZilla and giving those folders and files 777 permissions but that was no good either. 

I'm also having the same problem with the recommended requirements tab, I have installed all the extensions but the one which requires files to be accessed by the web server is unsolvable to me. 

image.thumb.png.f6ff69142ff39f6197aba665e0afb9b9.png

I have tried many different methods and tutorials but can't find a solution. 

I hope you guys could help me out ^_^ 

 

Thanks, 

Rokas 

find /home/xxxxxx/public_html/ -type f -exec chmod 0664 '{}' \;

find /home/xxxxx/public_html/ -type d -exec chmod 2775 '{}' \;


# In your servers “root” .bash_profile / .bashrc set:   root account of whm server
add the line “umask 002”

This will delegate root permissions to account for files inside the account owned by nobody or 999

Make sure, “public_html” dir has correct base ownership, likely accountname:nobody

Share this post


Link to post
Share on other sites
  • 0

This is what worked for me.  Your mileage my vary ;)


 

sudo chown www-data /var/www/html/config -R

sudo chgrp www-data /var/www/html/config -R

sudo chmod g+w /var/www/html/config -R

Bonus for cache folder
 

sudo chown www-data /var/www/html/cache -R

sudo chgrp www-data /var/www/html/cache -R

sudo chmod g+w /var/www/html/cache -R

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...