Jump to content
  • 0
Sign in to follow this  
ashevillewebhosting

Plesk NAT'd IP

Question

Hello,

Currently trialing Blest for use with my Plesk hosting business, and really liking it thus far! One issue I ran into is that in order for Blesta to provision a package, I seemingly have to use the private IP address of the server in the Plesk Module, otherwise, while it will create the customer, I get the following error with trying to create the package/subscription in Plesk:

domain.com
<?xml version="1.0" encoding="UTF-8"?>
<packet version="1.6.9.1">
  <webspace>
    <add>
      <result>
        <status>error</status>
        <errcode>1023</errcode>
        <errtext>Unable to get ip id by address 'domain.com' from db.</errtext>
      </result>
    </add>
  </webspace>
</packet>

If I use the private IP,  it works fine, however; from the Client portal the login link now uses this IP address, which is obviously not reachable for them. 

Any idea how I can overcome this? I really like the idea of being able to provide that login info to the client... one less question I have to field from them!

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi,

So after reading the thread below, I thought I'd give this a shot...

My issue was that my Plesk Onyx server used a single shared NAT'd IP. In Plesk, I had set the public IP via the IP Addresses page. This has worked fine when provisioning in Plesk directly. 

However, Blesta provisioning would throw the error above if I used anything (hostname, public IP) other than the local private IP. 

I added a second IP in Plesk, using the same public IP as the private was NAT'd too, and set it as dedicated. I left the original private/public as shared. 
I then set the server to use the public via Blesta's Plesk Module/Add Server, and retested the provisioning...

This time, I was able to create the customer AND provision the domain via Blesta without error. The login link for the client now works (minus the SSL warning).

 

So I have two questions I guess...

1. Network/DNS experts... any issues you can foresee with this IP config in Plesk? (screen shot attached)

2. Is there a way to define public/private yet in Blesta, or even better hostname, which is easier to secure with an SSL cert?
 

 

Screen Shot 2018-09-13 at 11.44.37 AM.png

Share this post


Link to post
Share on other sites
  • 0

Revised... Realized Blesta was provisioning the subscription using the dedicated IP, which obviously wont work for more than one site...

I changed the private IP address from shared to dedicated, and removed the public IP/NAT from it's settings.
I then set the the public IP entry from dedicated to shared.

Blesta now provisions to the shared public IP... and all appears to be happy?

If anyone has any insight, comments, etc. regarding this setup let me know... really hoping to be able to deploy Blesta in the coming days!

Screen Shot 2018-09-13 at 12.45.38 PM.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×