Jump to content
  • 0
zomex

New installation blank page

Question

Hello there,

Just started to install Blesta but running into issues.

After first uploading the files there was a blank page when visiting the root directory, after visiting /install.php I was able to get to the page after adding DB info but on this page it shows blank so there's no way for me to continue

Thanks

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Sorry for the waist of post. All sorted I just needed to use the PHP V7 hotfix.

Not sure if Blesta are aware of this but using the Ioncube encoder V10 for "PHP 5.6 & 7.1" will support PHP v5.6, v7, v7.1 & v7.2 using the same files

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, zomex said:

Sorry for the waist of post. All sorted I just needed to use the PHP V7 hotfix.

Not sure if Blesta are aware of this but using the Ioncube encoder V10 for "PHP 5.6 & 7.1" will support PHP v5.6, v7, v7.1 & v7.2 using the same files

As far as I know, the default files support PHP 5.4, 5.5, 5.6. php70-hotfix supports PHP 5.6 and 7.0, php71-hotfix supports PHP 7.1 and 7.2. Are you saying that the hotfix-php71 files support PHP 5.6-7.2? When we drop support for PHP 5.4 and 5.5 we'll be able to eliminate at least one hotfix.

Share this post


Link to post
Share on other sites
  • 0
On 10/29/2018 at 10:07 PM, Paul said:

As far as I know, the default files support PHP 5.4, 5.5, 5.6. php70-hotfix supports PHP 5.6 and 7.0, php71-hotfix supports PHP 7.1 and 7.2. Are you saying that the hotfix-php71 files support PHP 5.6-7.2? When we drop support for PHP 5.4 and 5.5 we'll be able to eliminate at least one hotfix.

I don't know of your files but yes the V7 hotfix is also what I use and it does support V5.6 to V7.2.

It may be worth having these files as default for Blesta rather than the 5.4 to 5.6 files as PHP V5.5 and below usage is so low now.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, zomex said:

I don't know of your files but yes the V7 hotfix is also what I use and it does support V5.6 to V7.2.

It may be worth having these files as default for Blesta rather than the 5.4 to 5.6 files as PHP V5.5 and below usage is so low now.

We will likely be changing the encoder for the default files soon for PHP 7. I'm surprised that the hotfix-php7 files are working for you on PHP 7.1 or 7.2, that was not our experience and why we ship a hotfix-php71 directory for 7.1 & 7.2.

Share this post


Link to post
Share on other sites
  • 0
On 11/14/2018 at 10:07 PM, Paul said:

We will likely be changing the encoder for the default files soon for PHP 7. I'm surprised that the hotfix-php7 files are working for you on PHP 7.1 or 7.2, that was not our experience and why we ship a hotfix-php71 directory for 7.1 & 7.2.

this will be great idea

but what if the provider is having php <7?

will you be providing the hotfix for the lower versions as well then

Share this post


Link to post
Share on other sites
  • 0
On 11/15/2018 at 12:14 PM, Amit Kumar Mishra said:

this will be great idea

but what if the provider is having php <7?

will you be providing the hotfix for the lower versions as well then

Yes, unless we raise the minimum requirements so that it does not matter.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×