Jump to content
  • 0
adamjedgar

Setting up Virtualmin Module

Question

Hi guys,

i have previously tried to install blesta and gave up choosing instead to use whmcs.

 I have just returned to Blesta in an attempt to get it functioning correctly and have successfully got the install part sorted.

I am now installing a Virtualmin Module (I use Virtualmin GPL)

 

i am just wondering if there is a complete guide for performing the virtualmin install as i have some questions.

 

1. Hostname? shouldnt this be hostname.fqdn? (ie server1.mydomain.com )

2. user name - should this be the root user for the virtualmin server on which client hosting accounts are going to be setup? (in whmcs its the server root user.  program needs to be able to create new virtualmin virtual servers)

3. which port should be assigned? should it be the virtualmin standard port (10000) or https (443). I assume port 10000?

Finally, when i setup as indicated above;

Blesta is not saving any new packages i create.

For example, under Module Options,

Server Group =Virtualmin server

Virtualmin Plan = "blank" (nothing to select in the dropdown)

Virtualmin Template = "blank" (nothing to select in the dropdown)

 

It appears to me that blesta is not able to communicate with virtualmin in order to sync the available virtualmin virtual server templates ii have setup on the server and then display them in the dropdown box.

 

 

 

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0
30 minutes ago, adamjedgar said:

1. Hostname? shouldnt this be hostname.fqdn? (ie server1.mydomain.com )

Yes. Something like server1.yourdomain.com would be ideal. You don't want to use a hostname that you are going to add to the server. For example, if you were doing to add yourdomain.com to the server you wouldn't want the server to be named just "yourdomain.com" but server1.yourdomain.com would be fine.

30 minutes ago, adamjedgar said:

2. user name - should this be the root user for the virtualmin server on which client hosting accounts are going to be setup? (in whmcs its the server root user.  program needs to be able to create new virtualmin virtual servers)

Yes, root.

30 minutes ago, adamjedgar said:

3. which port should be assigned? should it be the virtualmin standard port (10000) or https (443). I assume port 10000?

10000 is the default port, and it can be https://.

 

32 minutes ago, adamjedgar said:

Finally, when i setup as indicated above;

Blesta is not saving any new packages i create.

For example, under Module Options,

Server Group =Virtualmin server

Virtualmin Plan = "blank" (nothing to select in the dropdown)

Virtualmin Template = "blank" (nothing to select in the dropdown)

Yes, it sounds like Blesta is not able to connect to Virtualmin. In Blesta, double check that hostname is correct, user is root, password is correct, and port is 10000. If you login to Virtualmin with https:// on 10000 then check the "Use SSL" box.

You can check Tools > Logs: Module tab to see if there are any logs for Virtualmin. Click the row (not the link) to expand and show the raw input/output. This may be helpful to debug or confirm that no response is returned.

Make sure port 10000 TCP egress is open at your firewall on your Blesta server. This is the most common issue, as 10000 is not a common port it's typically closed if there is a firewall.

Share this post


Link to post
Share on other sites
  • 0

virualmin.png

Here's an example configuration. You may also want to check that you have created a server group, assigned the server to the group, and select the group when creating a Package. Sometimes not using a group can be a problem in some older versions of Blesta.

Share this post


Link to post
Share on other sites
  • 0

virtualmin-2.png

Here's an example (Package top, Logs bottom) of a working virtualmin integration. You can see the Server Group is named "Los Angeles" and after selecting it the Virtualmin Plans and Setting Templates are shown below. The log of that request is in the bottom screenshot, and is roughly what you should see in your logs.

Share this post


Link to post
Share on other sites
  • 0

thanks guys, i wiill try the above.

1. Do i need to setup fiirewall egress rules if blesta is on the same server as the virtualmin resources and templates i intend to use?

 

2. I am able to run the manual Cron however i am not convinced it is actually working as it says it s backing up to s3 bucket. i dont have an s3 bucket so how can this part complete successfully? (see cron details below)

Attempting to run all tasks for My Company.
Attempting to renew services and create invoices.
The create invoices task has completed.
Attempting to apply credits to open invoices.
Attempting to apply credits for client group General.
Completed applying credits for client group General.
There are no invoices to which credits may be applied.
The apply credits task has completed.
Attempting to auto debit open invoices.
The auto debit invoices task has completed.
Attempting to deliver invoices scheduled for delivery.
No invoices are scheduled to be delivered.
The deliver invoices task has completed.
Attempting to provision paid pending services.
The paid pending services task has completed.
Attempting to suspend past due services.
The suspend services task has completed.
Attempting to unsuspend paid suspended services.
The unsuspend services task has completed.
Attempting to cancel scheduled services.
The cancel scheduled services task has completed.
Attempting to process service changes.
The process service changes
task has completed.
Attempting to process renewing services.
The process renewing services task has completed.
Attempting to send payment reminders.
The payment reminders task has completed.
Attempting plugin
cron for order accept_paid_orders.
Finished plugin
cron for order accept_paid_orders.
Attempting plugin
cron for support_manager poll_tickets.
Finished plugin
cron for support_manager poll_tickets.
Attempting plugin
cron for support_manager close_tickets.
Finished plugin
cron for support_manager close_tickets.
Attempting plugin
cron for support_manager delete_tickets.
Finished plugin
cron for support_manager delete_tickets.
Attempting to clean up old logs.
0 old Gateway logs have been deleted.
0 old Module logs have been deleted.
The clean logs task has completed.
All tasks have been completed.
Attempting to run all system tasks.
Attempting to validate the license.
The license validation task has completed.
Attempting to backup the database to AmazonS3.
The backup completed successfully.
The AmazonS3 database backup task has completed.
Attempting to backup the database via SFTP.
The backup completed successfully.
The SFTP database backup task has completed.
All system tasks have been completed.

 

3. i am still not able to select any virtualmin virtual server templates...its not working

Share this post


Link to post
Share on other sites
  • 0
10 hours ago, adamjedgar said:

1. Do i need to setup fiirewall egress rules if blesta is on the same server as the virtualmin resources and templates i intend to use?

You may. Port 10000 TCP egress should be open.

10 hours ago, adamjedgar said:

2. I am able to run the manual Cron however i am not convinced it is actually working as it says it s backing up to s3 bucket. i dont have an s3 bucket so how can this part complete successfully? (see cron details below)

The output looks right. The messages indicate those tasks have run successfully, but do not necessarily mean that backups were sent to S3. If it's not configured to send backups to S3, then it wouldn't send them. Just indicates that the task ran that would do this. Since there was no error, the task was successful. I hope that makes sense.

10 hours ago, adamjedgar said:

3. i am still not able to select any virtualmin virtual server templates...its not working

What do the logs show (Tools > Logs > Module tab)? Sounds like it's not able to connect. Make sure the SSL setting matches how you login. Make sure you have DNS resolvers, or use the IP address. I tried to be as thorough as possible in my screenshots above. If there are no plans listed, they either do not exist in Virtualmin or it can't connect. Log will show you if it can connect.

If you want me to take a look and can provide root access to your Virtualmin server & Blesta server (If same server that works) and Blesta Admin login, you can PM me or open a ticket with us. I'll take a look, and then you can change your password after.

Share this post


Link to post
Share on other sites
  • 0

i was looking through my website options in virtualmin for the blesta installation and i noticed that the php script execution mode is set to FCGId (run as virtual server owner). 

 

does FCGId still allow use for .htacess? (i thought it used php.ini)

 

Will this cause my problem or is it not related to the issue i am having?

 

Share this post


Link to post
Share on other sites
  • 0

As far as I know it allows .htaccess, this has more to do with the mod_rewrite Apache module than your PHP. If you are having issues, edit httpd.conf and look for:

AllowOverride

and set them all to

AllowOverride all

Then restart Apache: systemctl restart httpd

Share this post


Link to post
Share on other sites
  • 0

Just an update on the original problem....

I changed server hostname entry in blesta to my server public (external) ip address and instantly i now see the virtualmin virtual server templates when creating new packages in blesta.

 

I dont know why the hostname.fqdn isnt working?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...