Jump to content
  • 0
Dave

WHMCS Import has invalid amounts owing.

Question

Howdy,

I am testing out Blesta and ran the WHMCS Import process, but it appears invoices were imported incorrectly.

My WHMCS install is setup to use "Inclusive Tax", so that all prices are entered with tax included. Blesta seems to assume that tax is excluded.

The problem is now all the old invoices in Blesta are showing as owing a taxable amount on top of the amount already paid.

Is there any way I can fix this automagically?

Dave.

 

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

So the invoice totals are different between the original and what is in Blesta? Would it be safe to say that removing tax on all imported invoices would result in the correct balance? We'll have to look into this, but it may be possible to make a simple tweak to prevent taxes from being added during import.

Share this post


Link to post
Share on other sites
  • 0

I'm not sure removing the tax would be the correct course of action because that would potentially lead to broken reports at a later date. I still need to know how much tax was paid per invoice (and not all line items or customers are taxed).

In my WHMCS install the "Taxation Type" setting under /setup/payments/tax is set to "Inclusive Tax - prices are entered including tax"

I've attached screen shots of the same paid invoice from WHMCS and Blesta after importing
The Blesta import has taken the taxable item and added an additional 10% (AU GST Tax) as the taxable amount to the total, rather than respecting the "Inclusive Tax" option and calculating the tax as a portion of the line item.
This now means that Blesta is reporting the invoice as underpaid.
 

90Blesta.PNG

90WHMCS.PNG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...