Jump to content
  • 0
kikloo

Blesta not showing directadmin packages

Question

Hi,

I recently got a new directadmin based server and I configured it in blesta (which is on some other server), when I am trying to add package in blesta, its not populating the directadmin reseller packages I have created in directadmin. What am I doing wrong ?

Please help, thanks in advance.

Thanks.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

There may be an error with the request, or something is not configured correctly.

You should go to add a new package, select Direct Admin, and when no reseller packages show up, take a look a the module logs Logs under Tools > Logs > Module tab. There may be some details/errors in the API requests logged there that could point to the issue.

Share this post


Link to post
Share on other sites
  • 0

Hi @kikloo you mention Reseller plans specifically, do your shared plans (if any) import in fine?

  • Is the user set in your directadmin module an administrator that can provision reseller services?
  • Is there a firewall blocking the two servers from communicating with eachother?
  • Have you correctly entered the DirectAdmin server information and password?

Share this post


Link to post
Share on other sites
  • 0

The DirectAdmin module requires those fields when creating a package. They should appear under the module options section of the package. If you don't see them, check your module and error logs for more information.

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, Tyson said:

The DirectAdmin module requires those fields when creating a package. They should appear under the module options section of the package. If you don't see them, check your module and error logs for more information.

This is what I see:

Direction 	Data 				Date 			Status
Input	myserver.myserver.net|getPackagesUser	2019-Nov-06 9:12:22 PM	 Success
Output	myserver.myserver.net|getPackagesUser	2019-Nov-06 9:12:23 PM	 Error
	a:0:{}	

 

Share this post


Link to post
Share on other sites
  • 0
16 hours ago, S.H. said:

This is what I see:


Direction 	Data 				Date 			Status
Input	myserver.myserver.net|getPackagesUser	2019-Nov-06 9:12:22 PM	 Success
Output	myserver.myserver.net|getPackagesUser	2019-Nov-06 9:12:23 PM	 Error
	a:0:{}	

 

Your DA server did not respond. Make sure your firewall on your Blesta and DA server has the DA ports open, they are non-standard so they are closed by default on most firewalls. Make sure your settings are correct. Make sure you have CURL SSL. If all the above is fine, make sure your server can negotiate a high enough TLS protocol that your DA server will accept. See https://docs.blesta.com/pages/viewpage.action?pageId=10551368#Debugging/Tools-CheckPHPCURL,outboundTLSVersion for how to test.

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, Paul said:

Your DA server did not respond. Make sure your firewall on your Blesta and DA server has the DA ports open, they are non-standard so they are closed by default on most firewalls. Make sure your settings are correct. Make sure you have CURL SSL. If all the above is fine, make sure your server can negotiate a high enough TLS protocol that your DA server will accept. See https://docs.blesta.com/pages/viewpage.action?pageId=10551368#Debugging/Tools-CheckPHPCURL,outboundTLSVersion for how to test.

Curl check script reports: TLS version: TLS 1.2.

Would anyone here by willing to try connecting to my DirectAdmin server, I can PM the login details. The server is new and empty, no client accounts have been made as yet so I am willing to do this if someone will help me. At least if it works then it would help me pinpoint which server has the issue, whether its the one with my Blesta installed or the one with DirectAdmin installed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...