Jump to content
  • 0
sunrisepro

Payment url incorrect after migrating Blesta to a new domain

Question

I moved Blesta from domain1.com/blesta to blesta.domain2.com.

The 'Pay Now' (without logging in) link in invoices is incorrect and I don't know where to fix it.

It should be

blesta.domain2.com/client/pay/method/...

But instead it's

domain2.com/client/pay/method/...

Where do I set the base url for the site? After migrating I went through every single setting, I must have missed where to set the url.

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0
5 hours ago, Paul said:

Step 3:

Hostname by definition would include anything.domain.tld. If we just said "Domain" I could see how that would be incorrect, which would be different than hostname. What would you suggest we add for more clarity?

Blesta detects the hostname during installation automatically. When moving Blesta if the hostname changes it must be updated, which is indicated in the documentation. Not sure what we can do to improve this. Suggestions welcome.

There is no 'Basic Setup' option, that's part of the problem. I would start with changing it to System > Setup > Companies and then explain how the company url field is relevant. That's the actual problem and I only found it by going through every single Blesta setting until I found the url field in Companies.

Share this post


Link to post
Share on other sites
  • 0
37 minutes ago, Tyson said:

Did you remember to edit your company's hostname under Settings > System > Companies?

I did, but I used the actual company domain and not the subdomain that Blesta is on. I assume I have to enter the subdomain there?

Share this post


Link to post
Share on other sites
  • 0
9 minutes ago, sunrisepro said:

I did, but I used the actual company domain and not the subdomain that Blesta is on. I assume I have to enter the subdomain there?

Hostname is the FQDN, if you are using a subdomain then that must be included.

Share this post


Link to post
Share on other sites
  • 0
19 minutes ago, Paul said:

Hostname is the FQDN, if you are using a subdomain then that must be included.

Got it. This is really a usability fault on your part, there's nothing at all there noting that domain setting decides the base url for the site. Most CMS's have a specific settings page for such an important setting. Currently it simply appears to be a bit of contact info.

Share this post


Link to post
Share on other sites
  • 0
On 11/15/2019 at 10:16 AM, sunrisepro said:

Got it. This is really a usability fault on your part, there's nothing at all there noting that domain setting decides the base url for the site. Most CMS's have a specific settings page for such an important setting. Currently it simply appears to be a bit of contact info.

It's mentioned in the documentation on Moving Blesta Final Steps > #3 for hostname, and #2 for updating path settings.

Share this post


Link to post
Share on other sites
  • 0
17 minutes ago, sunrisepro said:

Nothing on that page mentions the url field of the company settings. 

Step 3:

Quote

If the hostname changed, be sure to update it under Settings > System > Companies.

Hostname by definition would include anything.domain.tld. If we just said "Domain" I could see how that would be incorrect, which would be different than hostname. What would you suggest we add for more clarity?

Blesta detects the hostname during installation automatically. When moving Blesta if the hostname changes it must be updated, which is indicated in the documentation. Not sure what we can do to improve this. Suggestions welcome.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...