Jump to content
  • 0
vedova

Order section - page doesn't work

Question

Hello my few questions right for you, tried with chat but seems that is not working now.

Next to complete my test, i will transfer probably the installation to a subdomain so it's time to prepare to buy a own license after migration and new website is deployed. What i cannot fix is the Order section that doesn't work at all, clicking on order it simply reload the portal. Have fixed all with mod_security, rewrite, route file etc.. but something seems to missing... where i can put this help request if i'm on trial license? also need a trial license reissue as i'm going to move the website to a subdomain / different folder, now. And let the main third level domain to the web developer while i will continue to "play" with Blesta.

In browser bat it looks like to go to to /order/forms/ then went back to the portal home! Test product and group and prices and curreny are ok. Client section works and i can enter in.

I read about a 30% discount for who migrates from another billing platform, it's still valid? sorry but last week if i add a registrar module, it will go in conflict with the internet.bs one of that billing cms , than everything finish in a "Oooops" and MySQL DB completely corrupted and the only way to fix (with the backup DB :_) is to use the module given directly from the registry and not the software house in bundle with that billing cms, so i'ts time to start migrate... i have a owned license on it but after 10 years, and for someone it's like a golden palace to have, but nothing has been changed in problems! Still in wordpress if i remove a module it returns to work normally... with that CMS , damn, no! :D Absurd!

Regards,

Emanuele

 

 

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0
9 minutes ago, vedova said:

What i cannot fix is the Order section that doesn't work at all, clicking on order it simply reload the portal.

What do you have set for your default order form under Packages > Order Forms > Settings tab? Did you create an order form? Is the order form visibility public?

10 minutes ago, vedova said:

I read about a 30% discount for who migrates from another billing platform, it's still valid?

For like-license, yes. So if you have an owned license with a competing product, then we can get you a coupon with proof of purchase. Email sales proof of purchase. If it's not one of the most common competing products, then we have discretion on whether it qualifies.

12 minutes ago, vedova said:

sorry but last week if i add a registrar module, it will go in conflict with the internet.bs one of that billing cms , than everything finish in a "Oooops" and MySQL DB completely corrupted and the only way to fix (with the backup DB :_) is to use the module given directly from the registry and not the software house in bundle with that billing cms, so i'ts time to start migrate... i have a owned license on it but after 10 years, and for someone it's like a golden palace to have, but nothing has been changed in problems! Still in wordpress if i remove a module it returns to work normally... with that CMS , damn, no! :D

I'm not sure what you mean, is this for Blesta or for a competing product?

Share this post


Link to post
Share on other sites
  • 0
11 minutes ago, Paul said:

>What do you have set for your default order form under Packages > Order Forms > Settings tab? Did you create an order form? Is the order form visibility public?

here in attach

>I'm not sure what you mean, is this for Blesta or for a competing product?

I don't want to give product names, as i'm currently using it :) but i believe from the "setup" UI that it's the main competitor as it's look like going to be similar :D

Btw if i click on the link "test order form" from the administrator (that is logged in) i will be routed correctly to /order/cart/index/test%20order%20form/  just checked.

 

Screenshot 2020-05-18 at 17.36.55.png

Share this post


Link to post
Share on other sites
  • 0

Another question:

how i can use the Amazon S3 backup with a compatible S3 bucket provider? We have a storage bucket ourselves, but have to chose a different qualified domain in order to make it working.

I can select the Amazon region only, but nothing about another domain from the drop down menu.

Screenshot 2020-05-18 at 17.48.14.png

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, vedova said:

 

Screenshot 2020-05-18 at 17.36.55.png

What's under the "Settings" tab, what is the default order form set to? If you click Edit on this order form, is it set to public for visibility?

3 hours ago, vedova said:

Another question:

how i can use the Amazon S3 backup with a compatible S3 bucket provider? We have a storage bucket ourselves, but have to chose a different qualified domain in order to make it working.

I can select the Amazon region only, but nothing about another domain from the drop down menu.

Screenshot 2020-05-18 at 17.48.14.png

The Amazon S3 backup option only supports Amazon and not other storage hosting providers that emulate Amazon S3. It may be possible to modify the code to change the API URL to use another provider, but it's not officially supported.

Share this post


Link to post
Share on other sites
  • 0

Hello Paul,

here I am...

new subdomain, fresh installation.

Same problem.

This how its look on.

Only if I select a default order form it will show something on the order page, anything else not (even I've created 2 order forms).

Screenshot 2020-05-22 at 20.47.54.png

Screenshot 2020-05-22 at 20.48.05.png

Screenshot 2020-05-22 at 20.49.45.png

Share this post


Link to post
Share on other sites
  • 0

New problem:

on the order form when I'm trying to drag & drop it's ok, and works, but when I click on the "Edit Form" button, it will logout me instantly and I will go to a dark background page with a white login form.

 

 

Screenshot 2020-05-22 at 20.44.42.png

Screenshot 2020-05-22 at 20.44.49.png

Share this post


Link to post
Share on other sites
  • 0

The only reason I can think that you'd be logged out is if there is a firewall or proxy or mod_security rule that is being triggered for some reason. Nobody else has reported this, never heard of anyone being logged out when saving an order form before.

Share this post


Link to post
Share on other sites
  • 0
20 hours ago, Paul said:

The only reason I can think that you'd be logged out is if there is a firewall or proxy or mod_security rule that is being triggered for some reason. Nobody else has reported this, never heard of anyone being logged out when saving an order form before.

One word: Varnish 🙂

Thanks Paul for your chat support btw... it's true that in other installation with the Blesta concurrent works but it's true too that use varnish directly only by another cms in parallel cache with memcached, so completely different way/strategy ...

The last obstacle now it's internet.bs (and or openSRS) support, but this needs another thread as well :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...