Jump to content
  • 0

IonCube Loader installed, but cron fails and complains about it


Question

I'm on day 1 of my trial, running on Cyberpanel.  Things look fine so far, except cron doesn't run from the command line.  Instead I get this:

Quote

Site error: the ionCube PHP Loader needs to be installed. This is a widely used PHP extension for running ionCube protected PHP code, website security and malware blocking.

Please visit get-loader.ioncube.com for install assistance.

Now, 10.3 was installed when I installed the software in the first place, and CyberPanel makes it easy to install this extension so I've done so for all PHP versions (7.1 through 7.4).  I've tried running this from SSH with my site configured as PHP 7.2 and 7.3 and I get this error each time.

I'm not sure what to do next.  Running it manually from the Blesta panel runs fine.  But cron fails.

 

Help?

(Edited to add the following to establish I'm running the PHP I think I'm running...)

Quote

$ /usr/bin/php -v
PHP 7.2.24 (cli) (built: Oct 22 2019 08:28:36) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

 

php.PNG

When I run the loader-wizard.php file it tells me:

Quote

Loader Installed

The ionCube Loader version 10.3.9 for PHP 7.2 is already installed but it is an old version. It is recommended that the Loader be upgraded to the latest version if possible.

 

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

The CLI version of your PHP does not have the ionCube extension loaded. What is the path to PHP as shown under Settings > System > Automation? 

You ran /usr/bin/php -v, so I assume it is /usr/bin/php? You can run this command then to see if ionCube is loaded.

/usr/bin/php -i | grep ionCube

If nothing is returned, then it's not loaded.

/usr/bin/php -i | grep php.ini

This will show the path to your php.ini, which is probably where you'd need to load ionCube.

If /usr/bin/php is not the path to PHP as shown under Settings > System > Automation, then it's possible the path shown there may have ionCube installed. At least, it's Blesta best guess effort of determining where your PHP is.

Link to post
Share on other sites
  • 0

Thanks, Paul.  I went ahead and followed the directions to use wget in the cron script instead and that seems to be working.  Is it worth working to install ionCube for the command line version of php, or is sticking with the wget method fine for now?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...