Jump to content
  • 0

"The upload path could not be created." - Error in Invoice Customization


Go to solution Solved by Incog,

Question

I'm attempting to update the invoice format ( {month}{day}{year}{num} ), including the numeral start value and increment. But I am unable to save the changes due to the error shown in the title of this post. Nothing specific comes to mind, as I've been getting Blesta setup and attempting to get it ready to go in a live environment for about a week now. No other changes/adjustments have produced this error. Any ideas?

 

For the record, the uploads folder exists, and is writeable by Blesta.

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
  • Solution
On 1/25/2021 at 1:58 PM, Paul said:

If the cron runs as a different user as your web server, the ../logs_blesta/ logs directory will not be writable by the web server, or by the cron, which can create various issues

I want to say the issue was the upload directory was owned by a different user, but I'm not entirely certain. I don't recall modifying the cronjob or it's settings, but it's possible I have. Sorry, I should have noted it here!

 

The other, unrelated issue with email piping fixed itself after this issue was fixed. Still no php email piping, but IMAP works so I'll mark that as "good enough".

Link to post
Share on other sites
  • 1

What was the solution?

A couple things come to mind:

  • If the cron runs as a different user as your web server, the ../logs_blesta/ logs directory will not be writable by the web server, or by the cron, which can create various issues
  • Your uploads directory exists and is writable, but is missing some child directories. Here's some details and an outline what that structure should look like:

Make sure your uploads directory exists and is defined under Settings > System > General: Uploads Directory.

Some tips:

- The uploads directory should be above your document root or public_html directory so that it's not accessible directly via the web.
- A common path to the uploads directory would be something like: **/home/user/uploads/** 
- Make sure the uploads directory is writable by your web server and cron users. 755 permissions are usually sufficient, but you may need to set it to 777
- Inside the uploads directory, you should have a directory called 1 (for the company ID), and system.
- Plugins typically create their own directories within your company ID directory, but you may need to create them manually.

These are the directories you should have under uploads:

└── uploads
    ├── 1
    │   ├── download_files
    │   ├── invoices
    │   ├── mass_mailer_files
    │   └── support_manager_files
    └── system
 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...