Jump to content
  • 0

Can't upgrade to version 5 because 'Stripe Payments' is not compatible


Question

After upgrading blesta to 5.0.2, the 'Stripe Payments' plugin has stopped working.

There's always the same error after clicking pay: 

image.png.6d75f3c2e2e9fccf7d4bc8be1eab372c.png

 

However, blesta actually thinks the payment is processed successfully, and customers even get their e-mail: email-2.png.05b0a86a33c2ce6e2ea0251bc87caaa9.png

 

But if we check the gateway logs, in one of the stripe requests we get this: 

image.png.aec47093e14aec2da2190aa9495bdc92.png

 

Another customer is having the exact same issue, which the admins haven't responded with a solution yet. 

 

Help is much appreciated, Thank you. 

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
5 hours ago, Paul said:

Is this only an issue during checkout on the order form, or does this also happen when a client makes a payment from the client area? Interestingly, some report no issues. We're investigating.

Hi Paul, for me it only happens during checkout on from order form (all order form types). The invoice was generated but payment not captured. So the client needs to go to client area and pay the pending invoice. Card payment from the client area works fine even with stripe sandbox. I'm going to check the order form checkout using live mode if the same issue persists.

Link to post
Share on other sites
  • 0
On 2/6/2021 at 12:30 AM, Paul said:

Is this only an issue during checkout on the order form, or does this also happen when a client makes a payment from the client area? Interestingly, some report no issues. We're investigating.

Hi, thanks for the reply.

As the user above me commented, this only happens during the checkout in the order form. I think there is a compatibility issue with the plugin and stripe api responses.  I tried to do something about it with no luck. Looking forward to an update.  

Link to post
Share on other sites
  • 0
12 hours ago, kala said:

Anyone else is facing the issue when trying to add a payment account? We have clients complaining about this when they try to add a payment account and there is no log I could find at Strip about this. We have Version 4.12.3

That sounds like a completely separate issue from the one in this thread, should work fine on 4.12.3. Make sure you are forcing HTTPS, if your clients are connecting over http it will not work. Also, both your server and the client must support TLS 1.2+, so clients on old browsers and an old OS/Server will not work.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...