Jump to content
  • 0

support_manager poll_tickets Call to undefined function mailparse_msg_create()


BenWu
 Share

Question

Hello guys.

I cant call my mails via IMAP from support-manager...

Thats my error:
 

Attempting plugin cron for support_manager poll_tickets.
Call to undefined function mailparse_msg_create()
#0 /var/www/vhosts/DOMAIN/httpdocs/blesta/plugins/support_manager/components/ticket_manager/ticket_manager.php(96): MimeMailParser->setText('Return-Path: #1 /var/www/vhosts/DOMAIN/httpdocs/blesta/plugins/support_manager/support_manager_plugin.php(1349): TicketManager->processDepartmentEmails()
#2 /var/www/vhosts/DOMAIN/httpdocs/blesta/core/Automation/Tasks/Task/Plugin.php(68): SupportManagerPlugin->cron('poll_tickets')
#3 /var/www/vhosts/DOMAIN/httpdocs/blesta/core/Automation/Tasks/Task/Plugin.php(49): Blesta\Core\Automation\Tasks\Task\Plugin->process(Object(stdClass))
#4 /var/www/vhosts/DOMAIN/httpdocs/blesta/app/controllers/cron.php(675): Blesta\Core\Automation\Tasks\Task\Plugin->run()
#5 /var/www/vhosts/DOMAIN/httpdocs/blesta/app/controllers/cron.php(202): Cron->pluginTasks(1626207602.0164)
#6 /var/www/vhosts/DOMAIN/httpdocs/blesta/app/controllers/cron.php(150): Cron->all(1626207602.0164)
#7 /var/www/vhosts/DOMAIN/httpdocs/blesta/vendors/minphp/bridge/src/Lib/Dispatcher.php(142): Cron->index()
#8 /var/www/vhosts/DOMAIN/httpdocs/blesta/vendors/minphp/bridge/src/Lib/Dispatcher.php(61): Dispatcher::dispatch('/cron/', true)
#9 /var/www/vhosts/DOMAIN/httpdocs/blesta/index.php(24): Dispatcher::dispatchCli(Array)
#10 {main}
Finished plugin cron for support_manager poll_tickets. 

Attached my php config

Using Blesta 5.0.3

Bildschirmfoto von 2021-07-13 22-43-36.png

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

It is possible cron is using a different PHP install than what you're seeing on the web part.   For example, on a cpanel, plesk, or other control panel system you can multiple php versions and perhaps even different instances of the same version.  I suspect the cron is using one install while the web is using a different one.   So you need to check the cron is using the same PHP version and install as you're expecting. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...