Jump to content
  • 0

Recaptcha is blocking login. How do I DE-activate it via SFTP ?


turner2f

Question

Hello Support,

i am trying to setup Blesta.

After being in-active, I tried to login again.

But now I am locked out. The part where the Captcha is says, "
ERROR for site owner: Invalid key type "

Apparently I am using the wrong version of Google's Recaptcha.
 

============

I have looked all over the forum and documentation concerning this issue.

i have not even come across any instructions on which version to use.

============

1) - Recaptcha is blocking login. How do I DE-activate it via SFTP ?

2) - Which version of Google RE-captcha is the correct one to use ( V2 or V3 ) ?


 

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Got it figured out by doing a keyword search within the database.

I made the changes so that the Recaptcha Keys are for " V2 Invisible ".

==========

Please consider adding this info to your installation and trouble shooting instructions . . .

1) - Concerning the CORRECT version of ReCaptcha to use

2) - Concerning how to DIS-able or change it in the event of a lockout

Link to comment
Share on other sites

  • 0
On 10/9/2021 at 11:33 AM, turner2f said:

Got it figured out by doing a keyword search within the database.

I made the changes so that the Recaptcha Keys are for " V2 Invisible ".

==========

Please consider adding this info to your installation and trouble shooting instructions . . .

1) - Concerning the CORRECT version of ReCaptcha to use

2) - Concerning how to DIS-able or change it in the event of a lockout

This was not very complete answer, so I wanted to elaborate on this subject and answer a bit more for those that need to resolve this.

  1. Log into https://www.google.com/recaptcha/admin/site
  2. If you haven't already, create a site for Version 2.
  3. log into your database manager such as phpMyAdmin for your Blesta site (Mine was 5.2.2.)
  4. Search for clicking on the Database name, click on search and type "Captcha" in the box
  5. Locate the result x# matches in company_settings and click "Browse"
  6. Now copy your recaptcha_pub_key from your https://www.google.com/recaptcha/admin/site and replace the "Value" with your new Public Key in the Value box.
  7. Now copy your recaptcha_shared_key from your https://www.google.com/recaptcha/admin/site and replace the "Value" with your new Shared Key in the Value box.

Now reload your page and the Recaptcha Should now work.

Link to comment
Share on other sites

  • 0

So, tried to enable Google Enterprise API reCAPTCHA for 5.10.1, and got locked out.

Used Challenge v2 "I'm not a robot" Checkbox.

Was this the wrong version?

Does Blesta use Score based (v3) or v2 Invisible reCAPTACHA badge instead?

 

Or does Blesta require to use the Legacy key?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...