Jump to content
Alk

Modify "support" Text In Navigation Bar

Recommended Posts

Hello,

 

I would like to alter the "Support" text in the navigation bar for both the Staff and Client Portal:

 

post-78-0-64402800-1402773125_thumb.png

 

I have tried modifying the "Support" text entry in the file:

 

\plugins\support_manager\language\en_us\support_manager_plugin.php

 

line 12 & 13:

 

$lang['SupportManagerPlugin.nav_primary_client.main'] = "Support";
$lang['SupportManagerPlugin.nav_primary_staff.main'] = "Support";

However, in practise, it is not changing. Could anyone help please?

 

Thank you!

Share this post


Link to post
Share on other sites

Thanks Mike, unfortunately clearing the cache still hasn't altered the text in the nav bar. I think I must be editing the wrong language file, but I don't know what other file it could be.  :(

Share this post


Link to post
Share on other sites

I'm in the same boat. To be honest, I haven't spent any more time troubleshooting... But, I have done the same thing with the Pro module and it still says "Support Pro." I'll be curious what the final fix is.

Share this post


Link to post
Share on other sites

Thank you very much everyone; you have all helped me get to the bottom of this.

 

So when the plugin is installed, it takes the entry in the language file I mentioned and writes it to the database in table:

plugin_actions

In this table you will find 2 rows with these entries in the "action" column:

nav_primary_client
nav_primary_staff

(self-explanatory)

 

and these 2 rows will have the "support" text in the "name" column. Just go ahead and alter the text in the "name" column for the rows. Like so:

 

post-78-0-65233400-1402839970_thumb.png

 

Then clear your cache by deleting the "1" folder from the cache folder (eg. blesta_install_dir/cache/1/) (or use the emptycache plugin by naja7host) and reload the page. :)

Share this post


Link to post
Share on other sites

If this is changed in the database, it will also change the word for every other language. Or, did anything changed in the meanwhile and I didn't notice? :S

Anyone knows a quick workaround for this in the latest version (4.3)?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×