Jump to content

Blesta Integration 3.3.x (Advanced)


Recommended Posts

Hi,

 

I tried this guide and its not working with my template. How do I create my own theme ??

 

Thanks.

Well this guide is ment for users who want integrate header and footer from front end theme in to blesta.You need to do 2 things to work,1.upload css,js,img... files and 2. update links(paths) to that files you upload in structure.pdt  so browser can find it.

Link to post
Share on other sites

Hi,

 

I tried this guide and its not working with my template. How do I create my own theme ??

 

Thanks.

 

 

It's a guide to help you, you have to do what I did with your own template. If it's conflicting and causing issues you need to ensure you don't have two javascript files or two css files which are the same.

 

e.g.: bootstrap.css from blesta and bootstrap.css from your theme. Both will cancel each out.

Link to post
Share on other sites
  • 7 months later...
  • 8 months later...
24 minutes ago, Keystirras said:

Hey everyone, the guide works for the most part, i've just encountered one problem, on a client's account page it doesn't show any of the packages or anything, only the user's address/name etc. 

Anyone know how to fix this?

 

https://gyazo.com/56992b28e87b9110de248d901ac54268

that could be you have two Javascripts or something is conflicting try moving the JS up and down.

Link to post
Share on other sites
  • 6 months later...

I'm back! So i'm re-working my theme (So i started to re-do the integration) i was clearing up some code and i found that there is a blank spot at the top of my page above my navigation bar which is kinda hard to see with screenshot but is here: https://gyazo.com/b7c52c1308d7bb0103a6ece662a73881

 

I played around with the header code and found that it goes away if i remove this set of code:

		<?php
		// Theme CSS
		if (isset($theme_css)) {
		?>
		<link href="<?php $this->Html->_($theme_css);?>" rel="stylesheet" type="text/css" media="screen" />
		<?php
		}
        if ($this->_("AppController.lang.dir", true) == "rtl") {
        ?>
        <link href="<?php echo $this->view_dir;?>css/rtl.css" rel="stylesheet" type="text/css" media="screen" />
        <?php
        }
		?>

I was wondering what could be causing this problem?

Link to post
Share on other sites
  • 4 months later...
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...