Jump to content
  • 0
Sign in to follow this  
phireuk

Home Directory /blesta/ On A Vestacp Install.

Question

Hi

 

I installed Blesta yesterday on a vestaCP VPS.

 

All working fine.   The reason I chose vestaCP was because it has LAMP + fail2ban out of the box with no config needed. 

 

So since installing, people land on my site http://hosting.xxxxxxxx.uk/blesta

 

I read how you can change the root director in the database in the table [settings] > [root_web_dir]

 

my URL here currently reads

/home/admin/web/hosting.xxxxxxxx.uk/public_html/

So my question is, does anyone know the way I can make the home page become.

 

http://hosting.xxxxxxxx.uk/

and not

 

http://hosting.xxxxxxxx.uk/blesta/

 

Thanks for looking =)

 

After I have done this (then my next task will be force HTTPS + SSL cert.)

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Hi. today i'm installing blesta on vestacp too.

Everything is pass during setup req.

but after create a staff to login dashboard, i got blank screen. huft

Share this post


Link to post
Share on other sites
  • 0

Hi

 

I installed Blesta yesterday on a vestaCP VPS.

 

All working fine.   The reason I chose vestaCP was because it has LAMP + fail2ban out of the box with no config needed. 

 

So since installing, people land on my site http://hosting.xxxxxxxx.uk/blesta

 

I read how you can change the root director in the database in the table [settings] > [root_web_dir]

 

my URL here currently reads

/home/admin/web/hosting.xxxxxxxx.uk/public_html/

So my question is, does anyone know the way I can make the home page become.

 

http://hosting.xxxxxxxx.uk/

and not

 

http://hosting.xxxxxxxx.uk/blesta/

 

Thanks for looking =)

 

After I have done this (then my next task will be force HTTPS + SSL cert.)

 

Put the files for blesta in the in the public_html folder.

Share this post


Link to post
Share on other sites
  • 0

Put the files for blesta in the in the public_html folder.

 

Thats what i presumed but didn't want to break anything, when searching the only reference I could find was the root_web_dir thread which made me think twice.

Thanks for your help & the quick reply.

Loving Blesta so far compared to WHMCS

Share this post


Link to post
Share on other sites
  • 0

The Root Web Directory setting is configurable through the admin interrface under [settings] -> [system] -> [General]. No need to manually edit the database.

 

But if you installed it by directly unziping the 3.x.x blesta zip file (packaged in the blesta dir), and running the installer, then the correct root does not show in settings>system>general, not sure if that's unique to vestaCP installs (don't see how it could be).

 

It shows

/home/admin/web/hosting.xxxxxxx.uk/public_html/

not

/home/admin/web/hosting.xxxxxxx.uk/public_html/blesta

 

anyway moved it manually now and all's good.

 

Can't wait to make a Vesta, Blesta sandwich...Thats Vesta running Blesta controlling another vesta.

Share this post


Link to post
Share on other sites
  • 0

But if you installed it by directly unziping the 3.x.x blesta zip file (packaged in the blesta dir), and running the installer, then the correct root does not show in settings>system>general, not sure if that's unique to vestaCP installs (don't see how it could be).

 

It shows

/home/admin/web/hosting.xxxxxxx.uk/public_html/

not

/home/admin/web/hosting.xxxxxxx.uk/public_html/blesta

 

anyway moved it manually now and all's good.

 

Can't wait to make a Vesta, Blesta sandwich...Thats Vesta running Blesta controlling another vesta.

 

it doesn't show the Blesta folder it shows the Root folder.

Share this post


Link to post
Share on other sites
  • 0

it doesn't show the Blesta folder it shows the Root folder.

 

Well yes, Exactly.  so therefore not possible to change (the root domain URL) from settings if you didn't install in directly in root (public_html), but in a sub folder.   I think the installer should point this out, especially as it's packaged in a folder called Blesta inside a zip called blesta.  #justsayin

Share this post


Link to post
Share on other sites
  • 0

Well yes, Exactly.  so therefore not possible to change (the root domain URL) from settings if you didn't install in directly in root (public_html), but in a sub folder.   I think the installer should point this out, especially as it's packaged in a folder called Blesta inside a zip called blesta.  #justsayin

 

Haha the guys never used to put it in a folder but people complained :)

Share this post


Link to post
Share on other sites
  • 0

But if you installed it by directly unziping the 3.x.x blesta zip file (packaged in the blesta dir), and running the installer, then the correct root does not show in settings>system>general, not sure if that's unique to vestaCP installs (don't see how it could be).

 

It shows

/home/admin/web/hosting.xxxxxxx.uk/public_html/

not

/home/admin/web/hosting.xxxxxxx.uk/public_html/blesta

 

The root web directory is expected to be the system's root web directory, not Blesta's installed web directory. The cron needs to know this information, for example, to properly generate URL's used in email templates. If the value is incorrect, links in emails may not be valid either. You should check emails sent automatically by cron to make sure the links are working properly.

Share this post


Link to post
Share on other sites
  • 0

Haha the guys never used to put it in a folder but people complained :)

 

You can't win ;)

 

You can please some of the people all of the time or all of the the people some of the time...

 

 

The root web directory is expected to be the system's root web directory, not Blesta's installed web directory. The cron needs to know this information, for example, to properly generate URL's used in email templates. If the value is incorrect, links in emails may not be valid either. You should check emails sent automatically by cron to make sure the links are working properly.

 

 

Yes thanks.  I already notice the cron.  simple to adjust though.  all running well now.  thank for your help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...