Jump to content
Jonathan

[Module] NameSilo Domain Module

Recommended Posts

On 11/19/2018 at 10:26 AM, Jonathan said:

What page do you get this on?  Are you on version 1.8.4?

I am on  ver 1.8.5

The page I get this on is when I try to managed the module.

Here is a stacktrace:

Printing Stack Trace: 
#0 [internal function]: UnknownException::setErrorHandler(8, 'Undefined varia...', '/...', 639, Array)
#1 .../vendors/monolog/monolog/src/Monolog/ErrorHandler.php(173): call_user_func(Array, 8, 'Undefined varia...', '/...', 639, Array)
#2 .../components/modules/namesilo/namesilo.php(639): Monolog\ErrorHandler->handleError(8, 'Undefined varia...', '/...', 639, Array)
#3 .../app/controllers/admin_company_modules.php(106): Namesilo->manageModule(Object(stdClass), Array)
#4 .../vendors/minphp/bridge/src/Lib/Dispatcher.php(142): AdminCompanyModules->manage()
#5 .../index.php(21): Dispatcher::dispatch('/admin/settings...')
#6 {main}

Edited by Panfilo
added additional info

Share this post


Link to post
Share on other sites
1 hour ago, Panfilo said:

I am on  ver 1.8.5

The page I get this on is when I try to managed the module.

Here is a stacktrace:

Printing Stack Trace: 
#0 [internal function]: UnknownException::setErrorHandler(8, 'Undefined varia...', '/...', 639, Array)
#1 .../vendors/monolog/monolog/src/Monolog/ErrorHandler.php(173): call_user_func(Array, 8, 'Undefined varia...', '/...', 639, Array)
#2 .../components/modules/namesilo/namesilo.php(639): Monolog\ErrorHandler->handleError(8, 'Undefined varia...', '/...', 639, Array)
#3 .../app/controllers/admin_company_modules.php(106): Namesilo->manageModule(Object(stdClass), Array)
#4 .../vendors/minphp/bridge/src/Lib/Dispatcher.php(142): AdminCompanyModules->manage()
#5 .../index.php(21): Dispatcher::dispatch('/admin/settings...')
#6 {main}

same issue occur with me and there is no solution yet.

Share this post


Link to post
Share on other sites

Hi guys. Could you do me a favour and try the following?

  1. Go to Settings -> Modules
  2. Click on Namesilo -> Manage
  3. Beside your Namesilo API user account, click the "Edit" link
  4. Now, press the "Update Account" button

Once you've completed the above, please see if the error persists or if it's now resolved.

Share this post


Link to post
Share on other sites
On 11/27/2018 at 6:17 PM, NETLINK said:

Hi guys. Could you do me a favour and try the following?

  1. Go to Settings -> Modules
  2. Click on Namesilo -> Manage
  3. Beside your Namesilo API user account, click the "Edit" link
  4. Now, press the "Update Account" button

Once you've completed the above, please see if the error persists or if it's now resolved.

still error

in_array() expects parameter 2 to be array, string given on line 2063 in /home/billmhosting/public_html/portal/components/modules/namesilo/namesilo.php 

Printing Stack Trace: 
#0 [internal function]: UnknownException::setErrorHandler(2, 'in_array() expe...', '/home/billmhost...', 2063, Array)
#1 /home/billmhosting/public_html/portal/vendors/monolog/monolog/src/Monolog/ErrorHandler.php(164): call_user_func(Array, 2, 'in_array() expe...', '/home/billmhost...', 2063, Array)
#2 [internal function]: Monolog\ErrorHandler->handleError(2, 'in_array() expe...', '/home/billmhost...', 2063, Array)
#3 /home/billmhosting/public_html/portal/components/modules/namesilo/namesilo.php(2063): in_array('', 'domain')
#4 [internal function]: Namesilo->validatePortfolio('', '23a26b38d5190113...', 'mukesh@gmail...', 'false')
#5 /home/billmhosting/public_html/portal/vendors/minphp/input/src/Input.php(539): call_user_func_array(Array, Array)
#6 /home/billmhosting/public_html/portal/vendors/minphp/input/src/Input.php(362): Minphp\Input\Input->validateRule('portfolio', Array, '', 'portfolio')
#7 /home/billmhosting/public_html/portal/components/modules/namesilo/namesilo.php(794): Minphp\Input\Input->validates(Array)
#8 /home/billmhosting/public_html/portal/components/modules/namesilo/namesilo.php(826): Namesilo->addModuleRow(Array)
#9 /home/billmhosting/public_html/portal/app/models/module_manager.php(564): Namesilo->editModuleRow(Object(stdClass), Array)
#10 /home/billmhosting/public_html/portal/app/controllers/admin_company_modules.php(395): ModuleManager->editRow('17', Array)
#11 /home/billmhosting/public_html/portal/vendors/minphp/bridge/src/Lib/Dispatcher.php(143): AdminCompanyModules->editRow()
#12 /home/billmhosting/public_html/portal/index.php(21): Dispatcher::dispatch('/portal/admin/s...')
#13 {main}

Share this post


Link to post
Share on other sites
On 11/27/2018 at 6:47 PM, NETLINK said:

Hi guys. Could you do me a favour and try the following?

  1. Go to Settings -> Modules
  2. Click on Namesilo -> Manage
  3. Beside your Namesilo API user account, click the "Edit" link
  4. Now, press the "Update Account" button

Once you've completed the above, please see if the error persists or if it's now resolved.

when i click update account, i get an error, "API returned non-200 HTTP code"

Share this post


Link to post
Share on other sites

Hmmm... A HTTP response code 0 means that cURL failed to connect to the remote server or failed to execute, so there is nothing to return. This could be due to a non-functioning DNS resolver, for example. Do you have root access to the server running Blesta?

Share this post


Link to post
Share on other sites
51 minutes ago, Jonathan said:

@NETLINK have you heard/seen anything new about a JSON version of their API?  Last I talked to them it was supposed to be getting worked on.

 I think moving to JSON and away from bad XML parsing would significantly help this module.

I haven't heard anything new. I don't think it's live yet. But I like JSON. I wouldn't have any issues switching.

Share this post


Link to post
Share on other sites
12 hours ago, NETLINK said:

Hmmm... A HTTP response code 0 means that cURL failed to connect to the remote server or failed to execute, so there is nothing to return. This could be due to a non-functioning DNS resolver, for example. Do you have root access to the server running Blesta?

yes i have root access on this server.

Share this post


Link to post
Share on other sites
14 hours ago, NETLINK said:

Hmmm... A HTTP response code 0 means that cURL failed to connect to the remote server or failed to execute, so there is nothing to return. This could be due to a non-functioning DNS resolver, for example. Do you have root access to the server running Blesta?

i solve the resolver problem, now it's fine for me.

should i use master branch?

Share this post


Link to post
Share on other sites

Hello, I am experiencing issues with this Namesilo v1.8.4 module as well. When using the order form to check domain availability it leads to http 500 timeout error.

On 11/27/2018 at 8:47 AM, NETLINK said:

Hi guys. Could you do me a favour and try the following?

  1. Go to Settings -> Modules
  2. Click on Namesilo -> Manage
  3. Beside your Namesilo API user account, click the "Edit" link
  4. Now, press the "Update Account" button

Once you've completed the above, please see if the error persists or if it's now resolved.

I have tried these steps and this too will eventually give 500 internal server error, request timeout. I am on Blesta v4.4.2. I checked my NameSilo API Manager to see if the server IP address is enabled and it is fine. In fact as far as I knew the module was working, I have no idea when it stopped working, the only changes I made to the system would have been to update Blesta itself. :(

Share this post


Link to post
Share on other sites

Hello. I'm using version 1.8.5

This happened when I'm trying to manage the account. Cannot add an account yet.

Undefined variable: link_buttons on line 639 in /home4/hostinge/public_html/billing/components/modules/namesilo/namesilo.php

Printing Stack Trace:
#0 [internal function]: UnknownException::setErrorHandler(8, 'Undefined varia...', '/home4/hostinge...', 639, Array)
#1 /home4/hostinge/public_html/billing/vendors/monolog/monolog/src/Monolog/ErrorHandler.php(173): call_user_func(Array, 8, 'Undefined varia...', '/home4/hostinge...', 639, Array)
#2 /home4/hostinge/public_html/billing/components/modules/namesilo/namesilo.php(639): Monolog\ErrorHandler->handleError(8, 'Undefined varia...', '/home4/hostinge...', 639, Array)
#3 /home4/hostinge/public_html/billing/app/controllers/admin_company_modules.php(106): Namesilo->manageModule(Object(stdClass), Array)
#4 /home4/hostinge/public_html/billing/vendors/minphp/bridge/src/Lib/Dispatcher.php(142): AdminCompanyModules->manage()
#5 /home4/hostinge/public_html/billing/index.php(21): Dispatcher::dispatch('/billing/index....')
#6 {main}

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...