Jump to content
Jonathan

[Module] NameSilo Domain Module

Recommended Posts

NameSilo Domain Module

This module is a complete solution for domain registrations and transfers through NameSilo.  This module builds upon and continues the work by @NETLINK.  He and I will be jointly contributing to this project and we welcome any other contributions on GitHub.

An old thread related to this plugin was at https://www.blesta.com/forums/index.php?/topic/3399-namesilo-plugin

Features

  • Domain registrations
  • Domain transfers
  • Supports all NameSilo-supported TLDs by dynamically listing the available ones to package creation
  • Proper .us/.ca support with necessary fields on order forms
  • NameSilo audits
  • Sync service's renewal date with domain expiration date
  • Register/manage nameservers/hosts
  • Set/change nameservers
  • Update WHOIS details
  • Lock/unlock domain
  • Retrieve EPP code
  • DNSSEC management
  • Check email validation & resend validation email if needed
  • Toggle WHOIS privacy
  • Manually extend registration
  • Transfer status tracking

Screenshots

Coming soon

Installation

https://github.com/knownhost/Blesta-Namesilo/blob/master/README.md

Upgrading

Nothing special is required except when updating from <1.8.0.  In this case see the "Other" section below.

Known Issues

  1. A domain transfer can be ordered for more than 1 year.  NameSilo's API does not allow a transfer to extend more than one year so the extra years would be lost if not manually corrected.  I'm unsure of how we'll solve this at this point.

Future Plans

  • Update for Blesta's new domain management system when release.  This will be the v2.0 milestone and will likely be mostly a rewrite of the module.
  • Clean code and remove unnecessary code.
  • Manually extending as an admin should support invoicing/queuing to post-payment.  We should be able to do this with the proration logic.
  • DNSSEC management Implemented!

Source

This module is fully open source and can be found on GitHub.  Two repos are kept fully updated with releases currently being built on the second:

https://github.com/knownhost/Blesta-Namesilo
https://github.com/NETLINK/Blesta-Namesilo

Download

I will make every effort to maintain the listing in the marketplace at https://marketplace.blesta.com/#/extensions/80-NameSilo Module

GitHub will always definitely be up-to-date: https://github.com/NETLINK/Blesta-Namesilo/releases

Other

The version 1.8.0 release is a major update building upon @NETLINK's work.  The new auditing features will not work properly until you "manage" and save your NameSilo account settings.  Everything else should be fully backwards-compatible.

Share this post


Link to post
Share on other sites

Hi Jonathan,

Excellent work on this Namesilo module. I was able to upgrade from v1.7 beta to v1.8.0. I have noticed 2 problems for which I need your guidance.

1. Manage Service -> Settings Tab: A message pops up saying "Registrant email verification status for : NOT VERIFIED!". So I tried to get it sorted but when I went to the Email Verification Manager page at Namesilo everything was already green and verified. Also is the domain name supposed to show up after the word "for" in the error message? I've attached a screenshot.

2. Audit Domains: The audit results all say "No corresponding billing record in Blesta". I did click to manage the Namesilo module then clicked "edit account" and finally "update account" to save the module settings but still no luck.

What do you suggest?

Do you think any of these are related to missing data in my database? Can you indicate what tables in the database are related to these errors and I can check if the data is there. I only have one row in the service_fields table for Namesilo services called "domain", are others required since the upgrade?

Namesilo settings tab error.jpg

Share this post


Link to post
Share on other sites
1 hour ago, S.H. said:

1. Manage Service -> Settings Tab: A message pops up saying "Registrant email verification status for : NOT VERIFIED!". So I tried to get it sorted but when I went to the Email Verification Manager page at Namesilo everything was already green and verified. Also is the domain name supposed to show up after the word "for" in the error message? I've attached a screenshot.

The email address associated with the domain's registrant should be there.  The issue is going to be somewhere around https://github.com/knownhost/Blesta-Namesilo/blob/master/namesilo.php#L1874

If I give you some debug code to put in can you do that?

1 hour ago, S.H. said:

2. Audit Domains: The audit results all say "No corresponding billing record in Blesta". I did click to manage the Namesilo module then clicked "edit account" and finally "update account" to save the module settings but still no luck.

Go to "Manage" on the NameSilo module.  Click "edit" next to your user(s), then click "Update Account".  Since you did that, what are the results of this query?

select * from module_row_meta where `key`='namesilo_module';

Share this post


Link to post
Share on other sites

The upgrade from v1.8.0 to v1.8.1 went smoothly. However, the problem with the registrant email verification still exists, and the Audit Domains button leads to a blank white page. This is the error from the logs, I removed my file path but the rest is unedited:

[2018-04-10 15:24:22] general.ALERT: Fatal Error (E_ERROR): Call to undefined function getnamesilorow() {"code":1,"message":"Call to undefined function getnamesilorow()","file":"/~blestapath/components/modules/namesilo/namesilo.php","line":653} 

 

Share this post


Link to post
Share on other sites
1 hour ago, Jonathan said:

Sounds like your line 653 doesn't match this:

https://github.com/knownhost/Blesta-Namesilo/blob/master/namesilo.php#L653

I repackaged the zip and made sure this is in there properly as it wasn't originally.  You just need to fix that line.

This has worked, Audit Domains button no longer leads to blank white page. However neither of the problems mentioned in my first post seem to have been affected. Nobody else has mentioned similar issues so I wonder if others have these issues or just me? :unsure:

It's never too soon for a feature tease. ;)

Share this post


Link to post
Share on other sites
6 minutes ago, S.H. said:

This has worked, Audit Domains button no longer leads to blank white page. However neither of the problems mentioned in my first post seem to have been affected. Nobody else has mentioned similar issues so I wonder if others have these issues or just me? :unsure:

It's never too soon for a feature tease. ;)

Try the debug code from our PM and let me know the results.

Share this post


Link to post
Share on other sites
4 hours ago, Jonathan said:

Try the debug code from our PM and let me know the results.

Ok I found your problem.  The fault actually lies in the fact that XML is horrible and the module is inconsistent in parsing it.  If you had multiple email addresses across your domains it would work as expected.

I've had to do hacky fixes on this XML parsing in several other instances now....lets do another!  I should have a fix for you later today or tomorrow.

@namesilo-admin is supposed to be working on a JSON API....it sure can't come soon enough!

Share this post


Link to post
Share on other sites
1 minute ago, Joseph H said:

It works perfectly :blesta:.... Only DNS Management Is missing, any plans of adding this any time soon mate

Glad it's working well for you!  This is something several people have requested but as I don't need it in my use case I haven't had any direct plans to add it.  If I'm ever bored working on the module I may, or you're welcome to do it yourself and submit pull requests on GitHub.

Share this post


Link to post
Share on other sites

Domain transfers require an EPP code to be entered.

I just installed version 1.8.3 but why is this message appear when I'm trying to register a new domain directly for a client inside admin dashboard?

Share this post


Link to post
Share on other sites
1 minute ago, isijosamua said:

Domain transfers require an EPP code to be entered.

I just installed version 1.8.3 but why is this message appear when I'm trying to register a new domain directly for a client inside admin dashboard?

What TLD are you trying to register?  Some of the ones with special requirements, namely .us and .ca have been a bit of a headache to properly implement so I'm wondering if this is surrounding some of the requirements of those.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...