Jump to content
furioussnail

Invalid package option value ID error

Recommended Posts

Hello.

I am getting the following errors when editing a package option under "Packages" -> "Options" -> "Edit" on desired option:

Invalid package option value ID.
Invalid package option pricing ID.
Invalid package option pricing ID.
Invalid package option pricing ID.
Invalid package option pricing ID.

I get the errors when I add an additional option and try to save. I set values as increments starting from 1. 1, 2, 3, 4...

Blesta 4

OS: Arch Linux

Browser: Chrome 57.0

Share this post


Link to post
Share on other sites
On 3/21/2017 at 9:20 PM, furioussnail said:

This seems to be random. At some points I get the error but when I try to reproduce it doesn't happen.

Hello,

did you figure in the past what the problem was? I am having the same problem with Blesta 4.3.1. I do the following:

1) Create a configurable options group.

2) Create an configurable options and assign the group.

But them when i open for edit the new option i created there are gone the options and pricings i set before. And when i try to save it says: "Invalid package option value ID.". Attached is the error.

Thank you,

regards.

errorblesta.png

Share this post


Link to post
Share on other sites
21 hours ago, Mariano said:

Hello,

did you figure in the past what the problem was? I am having the same problem with Blesta 4.3.1. I do the following:

1) Create a configurable options group.

2) Create an configurable options and assign the group.

But them when i open for edit the new option i created there are gone the options and pricings i set before. And when i try to save it says: "Invalid package option value ID.". Attached is the error.

Thank you,

regards.

errorblesta.png

What appears under the "Options" section? What did you change with the package option on edit?

Share this post


Link to post
Share on other sites

Hello, thank you for the reply. I was trying to set the options in the "options section". I was able to create and save the "options section", but when i reopened the configurable option for edit there are not more the values in the "options section" how there was when i first created the configurable option. And if i try to add the items in the "options section" again, there comes the error (Invalid package option value ID.) when i try yo save changes.

The strange thing is that today i tried to add again a configurable option from 0 and it worked. But still, the one i created yesterday says "Invalid package option value ID." when i try to modify the configurable option. Here is te one is not working (the values it shows when i open it -because didn't save the first values i put- and the values i try to set):

blesta5.thumb.png.902faa4e9c5f50cd8f996d1c46cb75b9.png  

blesta3.thumb.png.7a964580d30f702ad3f76c9d33877edd.png

But here is the one i tried to add from 0 today, it is working fine and i can modify and save it without problems (i did all exactly as yesterday, and used the same options and values):

blesta1.thumb.png.fe52d5dbf426943f27d6666486dfd495.png

blesta4.thumb.png.1b1cc18d1724fdff05204754552ebd92.png

Maybe it is just a random thing as the OP says?

Regards.

Share this post


Link to post
Share on other sites

Interesting. I wasn't able to duplicate that behavior.

But I am curious.. did you receive a message when you created the package option yesterday? Either a success message in a green box, or an error message in a red box?

Can you replicate this problem by creating the same package option with the same information and the same values/pricing? If so, please let me know the details so I can try it myself.

Share this post


Link to post
Share on other sites
12 hours ago, Tyson said:

Interesting. I wasn't able to duplicate that behavior.

But I am curious.. did you receive a message when you created the package option yesterday? Either a success message in a green box, or an error message in a red box?

Can you replicate this problem by creating the same package option with the same information and the same values/pricing? If so, please let me know the details so I can try it myself.

I confirm when i created the 1st package option (the one with error) i saw the success message. The package option was saved, but werent saved the items in the "options section" (or at least when i try to edit these package option they are not there). And  i can't update these package option because the error when i try to save.

Maybe now thinking, i can remember a little diference: betwen the 1st one and the 2nd one: because the error, i did an upgrade from 4.3.0 to 4.3.1 to try. Now, in the "options section" when i choose "Quantity" and in the "options section" i leave "min" or "max" empty, and try to save, it gives a white screen (wont save), and looking at the blesta logs it gives this error:

[2018-08-20 18:46:36] general.ERROR: PDOException: SQLSTATE[HY000]: General error: 1366 Incorrect integer value: '' for column 'min' at row 1 in

And there is a chance i leaved "min" or "max" empty the first time because they aren't requiered (only "step" is). I don't remember really and i can't confirm it because these records wheren't saved. Idk, for example, would happens that these values can't be empty, and the first time, before the pach, it allowed me to save and  there is some error in the DB with this item (relations or somehting)?

Anyway, not big deal, i will continue working and see how goes. If i can reproduce the error i put it here, for now i can't, it doesnt happens. For now the only strange i see is these white screen leaving these fields empty (min and max), it looks like if they are not validated before save like the other fields and needs to be.

Thank you,

regards.

 

 

Share this post


Link to post
Share on other sites

Thank you for providing additional information to help us duplicate the issue.

I'm not sure exactly why the package option was created without a value set, however, you should be able to delete that package option from the system and create another one instead.

I did encounter the error, as you described, when the "min" quantity is left blank. We will look into fixing that soon in CORE-2804.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...